npm 升级

 

 

当我们运行某个项目是 会提示

> my-first-vue-project@1.0.0 dev C:UsersASUSmy-project
> node build/dev-server.js


To use this template, you must update following to modules:

  npm: 2.15.9 should be >= 3.0.0

这是只有升级npm

即是 :使用 npm -g install npm@3.0.0 (版本号2.9.1 可以根据已发布的版本随意升级或降级),获取最新版本的npm 文件

查看版本:

这时在项目中进行  npm run dev 时还是会 提示

因此还有一部关键的一步:

复制C:Users{你的Windows用户名}AppDataRoamingnpmnode_modulesnpm下的文件到你的 NodeJS安装目录下的 node_modulesnpm 中,覆盖掉原有的全部文件

最后运行  npm run  dev 成功运行

希望对 你有所帮助

0 条评论
发表一条评论