关于wamp中升级PHP+Apache 的问题

首先个人不建议wamp中升级php版本,如果你不信可以试一试,当你php升级后发想,奥,Apache版本不匹配,然后又去升级Apache,结果搞了半天,弄出来了就好,要是没出来,可能你会气死(好吧,气了,还得继续。。。)。

如果非要升级php,那么方法如下(例如升级5.4.36版本):

1、从已存在的php版本文件中(如php5.3.10, (eg. wamp/bin/php/php5.3.3))复制以下文件: – php.ini、phpForApache.ini和wampserver.conf到php5.4.36文件夹. 

2、打开php5.4.36文件夹的以下文件: – php.ini和phpForApache.ini并且把5.3.10替换为5.4.36。用记事本打开ctrl+f查找替换即可 

3、去wamp/bin/apache/apache/apache2.2.22/bin删除php.ini文件 

4、将5.3.10文件夹中的php5apache2_2.dll和php5apache2_2_filter.dll复制到php5.4.36中去(下载官方版本名称中不带 nts 的php版本文件) 

5、记得修改 wampmanager.ini及wampmanager.conf里面的配置

5、重启wamp.此时就可以选择php->version-> 5.4.36

 

升级Apache到2.4.16:

1.下载Windows版的Apache 2.4.16安装包,下载地址http://www.apachelounge.com/download/
2.将安装包解压缩,并将解压后的文件夹Apache24复制到wampbinapache下,并更名为apache2.4.16
3.将wamp/bin/apache/apache2.4.9/wampserver.conf复制到wamp/bin/apache/apache2.4.16/
4.将/wamp/bin/apache/apache2.4.9/conf/httpd.conf复制到wamp/bin/apache/apache2.4.16/conf/,覆盖原来的httpd.conf
   编辑wamp/bin/apache/apache2.4.16/conf/httpd.conf文件,将”2.4.9″替换成”2.4.12″
5.如果有VirtualHost,则将/wamp/bin/apache/Apache2.4.9/conf/extra/httpd-vhosts.conf复制到/wamp/bin/apache/Apache2.4.16/conf/extra/,覆盖原来的
httpd-vhosts.conf
6.退出并重新进入WAMPServer,选择apache2.4.16,再退出并重新进入WAMPServer,启动所有服务。如果出现问题,请退出并重新进入WAMPServer试试。(不过我相信你还会遇到问题)。

升级wamp的最快捷的办法(推荐使用此方法):

1、进入官网下载,地址:https://sourceforge.net/projects/wampserver/

2、点击进入下一步:

 3、点击进入下一步:

4根据自己的要求下载不同的版本:

 

                                                                                                                                                                @author datou 2016-11-10 15:43:41


 

0 条评论
发表一条评论